Spamhaus blockage
Incident Report for Groups.io
Resolved
The Spamhaus block has been lifted and email is flowing again.
Posted Jan 16, 2024 - 07:10 PST
Update
We are continuing to work on a fix for this issue.
Posted Jan 15, 2024 - 09:22 PST
Identified
Spamhaus is blocking one of our email servers. For email systems that use Spamhaus, we are currently unable to deliver mail to them through this server. We are attempting to work with Spamhaus to resolve the issue.
Posted Jan 15, 2024 - 09:22 PST
This incident affected: Email.