Email delivery delayed
Incident Report for Groups.io
Resolved
Email is being delivered again.
Posted over 1 year ago. May 02, 2018 - 18:32 PDT
Identified
There is an issue with email delivery. We are working with Linode to resolve the problem.
Posted over 1 year ago. May 02, 2018 - 18:12 PDT