Delayed email delivery
Incident Report for Groups.io
Resolved
This incident has been resolved.
Posted Mar 20, 2020 - 10:40 PDT
Monitoring
Due to a corrupt file system, delivery of new messages stopped at 9:31pm Pacific Time on 3/19/20. Delivery of new messages was restarted at 7:50am on 3/20/20. It will take some time to work through the backlog of messages.
Posted Mar 20, 2020 - 08:09 PDT
This incident affected: Email.