Erroneous phishing warnings
Incident Report for Groups.io
Resolved
This incident has been resolved.
Posted over 1 year ago. Feb 26, 2018 - 09:01 PST
Investigating
Some users are seeing erroneous phishing warnings when visiting the site on Windows. We have contacted Microsoft, Norton and Avast to work to clear this up. To the best of our knowledge, there is no real issue with the Groups.io site.
Posted over 1 year ago. Feb 23, 2018 - 16:06 PST